Web: https://www.reddit.com/r/devops/comments/s0iasy/argocd_image_updater_not_updating_the_images/

Jan. 10, 2022, 11:50 a.m. | /u/sitilge

Everything DevOps reddit.com

I noticed that my argocd-image-updater is not updating the respective metafile .argocd-source-myapp.yaml even though there are multiple new images in the image-list repository. I can see the image updater updating the metafile ONLY when I update the chart itself and not when there is a new image in the registry.

These are my annotations:

apiVersion: argoproj.io/v1alpha1 kind: Application metadata:name: myapp namespace: argocd annotations: argocd.argoproj.io/sync-wave: "1" argocd-image-updater.argoproj.io/image-list:myapp=registry.gitlab.com/abc/myapp argocd-image-updater.argoproj.io/myapp.force-update: "true" argocd-image-updater.argoproj.io/myapp.update-strategy: latest argocd-image-updater.argoproj.io/myapp.ignore-tags: latest, master 

These are the pod logs:

time="2022-01-10T11:46:19Z" level=info msg="Processing results: applications=1 images_considered=1 images_skipped=0 images_updated=0 errors=0" time="2022-01-10T11:48:19Z" level=info msg="Starting …

devops

Sr. Manager, CRM Deployment

@ Ethos | Remote

Software Engineer, Infrastructure

@ Pilot | San Francisco, CA

Software Engineer - Terraform Ecosystem, Strategic Providers

@ HashiCorp | Germany (Remote)

Site Reliability Engineer

@ Menlo Security | Vancouver, British Columbia, Canada

Design Reliability Engineer (Spacecraft)

@ SpaceX | Brownsville, TX or Hawthorne, CA

インフラストラクチャーアーキテクト (マイグレーション) / Infrastructure Architect Migration Consultant

@ Amazon.com | Tokyo, JPN